Jump to content

Missing Mouse pointer on PC


Recommended Posts

My Mouse pointer has gone from my PC.

'Mice and other pointing devices ' is missing from 'Device Manager'

I have tried using 'Scan for 'Hardware Changes' in Device Manager (youtube tutorial)

this should show 'mice and other pointing devices' and reinstall it but does not show in list.

I am stumped.. any ideas as to how I can fix this problem



Link to comment
Share on other sites

morning DF

I googled Missing Mouse Pointer and found this


It may be useful, I don't know what system you have, but there is lots of infor online.

someone may be able to provide tailored support to you - I hope you get this fixed.


Link to comment
Share on other sites

Long time ago (when I did this) devices used to be found in device manager as "unknown device" or a device that is not working.

Maybe upgrading the device driver or removing and re-scanning anything like that would help.

Just checked mine and there's also "view"->"show hidden devices" - might show up something ?

Link to comment
Share on other sites

assume it's a wired USB mouse Foxy?

have you tried a different USB port and restarting? Any chance of using same mouse on a different pc?

I'm happy to send you a new mouse if you need one as I have a few spare - am sure someone more local will jump in before tho

Link to comment
Share on other sites

It's the mouse from my Touch Pad. not an actual separate mouse.

I have made a BIG mistake.. Following online instruction..

I disabled '12c HID' device. BUT I cannot Enable it because my Touch pad now is not working

and I do not have a Mouse.

I have tried calling Netquest but not answering

I am now using a 15 year old Windows XP machine with no email


Link to comment
Share on other sites

*** SORTED ***

I contacted a guy from Solid Rock IT UK Name Mark

Very Nice guy.. His workshop is currently closed but does Call outs..

Told him my problems and booked me in for a call out today.

I asked him about Starting in Safe Mode on Windows 10

He said . Power Down.. Hold Shift Key and power up...

I tried this and.... Everything came back up as normal .. with Cursor..

Was able to then Enable '12c HID' in device manager..

All fixed.

I Strongly recommend Mark

Solid Rock IT UK

38 Grove Vale

07951 878 703


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign In

Sign In

Or sign in with one of these services

    Search In
  • Create New...